Inability to correct missing data in form submission in Quform 2

Home Forums Quform WordPress Inability to correct missing data in form submission in Quform 2

This topic is: not resolved

This topic contains 3 replies, has 2 voices, and was last updated by  Ally 3 weeks, 2 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #23077

    DavidRomano
    Participant

    Since upgrading to Quform 2 I’ve found that if data is missed from a required field correcting the data and attempting to resend soemtimes results in a form error message. I have not yet been able to establish whether this results from the form data element or from the reCAPTCHA element.

    Has anyone else encountered this issue? If so what is the solution, please?

    #23116

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #23137

    DavidRomano
    Participant

    Hi Ally,

    The page I’m testing on contains a reCAPTCHA image and the initial problem seems to arise from latency in the reCAPTCHA cycle.

    If the form data is corrected and SEND clicked, the reCAPTCHA is detected as having expired so the error message I’m getting (An error occurred, please try again) is originating from reCAPTCHA.

    It looks, quite reasonably, that the reCAPTCHA cycle needs to be re-executed after any additional data is added.

    I think the error message (An error occurred, please try again) in the reCAPTCHA box arises from the form holding the old reCAPTCHA data but attempting to validate it against new reCAPTCHA data. The latency results as the reCAPTCHA box shows a green tick + the error message (An error occurred, please try again) leaving the user uncertain as to what’s gone wrong.

    What is making the situation more confusing is that required date fields (it does seem to be only fields with the data picker) on the form are showing their previously instantiated value but being reported having a missing value – see attached snipped image Ally Capture 1.

    Because the form is long the ideal behaviour would be to have all entered data preserved until SEND is executed.

    I think the behaviour I’m getting is that the onscreen form image is showing the last entered data but that the variable containing the data may be being cleared. As far as I can tell this may be just a problem affecting date fields so may be related to the date picker code.

    (The date picker is now active – re other support post)

    Attachments:
    You must be logged in to view attached files.
    #23193

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.