V 2.0.1 stopped sending mail after successfully sending at first

Home Forums Quform WordPress V 2.0.1 stopped sending mail after successfully sending at first

This topic is: not resolved

This topic contains 6 replies, has 2 voices, and was last updated by  patdundee 6 days, 22 hours ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #21915

    patdundee
    Participant

    Hi Guys
    Always used WP SMTP Mail for sending all forms.

    Worked well in V2.0.1 while V1.10 was installed. As all forms are now displaying correctly and were sending emails I removed V 1.10

    Now V 2.0.1 is no longer sending the emails through

    Reset up V 1.10 but still no joy

    All recipient and sender emails set up correctly and the form follows through and stores in the database with no errors. It has just suddenly stopped sending emails.

    Could you have a look please Ally has all the log details

    Page is http://www.kimboscakes.co.uk/contact-kimboscakes

    Form ID is form 1 Contact and reservations.
    It is the same aon all the other forms but this will be the easiest and quickest to fix i think

    Many thanks
    Patrick

    #21919

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #21922

    patdundee
    Participant

    Hi Ally (Additional read to last paragraph)
    Appreciate it
    I have tested the WP SMTP mail to both a local account on the same mail server and to a gmail account and both work fine.

    I think somwhere along the line the authentication is being asked for which it should not be when a user adds there email address. No auth is required for incoming mail. On checking the mail logs (I run my own servers and mail servers) i see this error

    Sorry from is not for local domain or auth user didn't match

    That would suggest to me that somewhere in the new form the from address is being set as the to address and the to address being the from address. That being the case authentication would be required.

    Just as a point, other servers here running V1.10 still and using the same WP_SMTP_MAIL do not have the issue 🙂

    I have just tested the above theory by changing the Form–>Settings..>Notification–>Admin Notification
    I changed the to address to the site email address and the reply to as the email element in the form and the from email address as the site email address and it worked fine..
    Somewhere along the line this gets mixed up when the form is posted it seems to happen on all the forms.

    the from needs correcting to the email element and the to needs to be as it is the site address and the reply to needs to be the email element.

    Let me know when you find where it is changing and correct so i can change the forms back (or you have my log in you could change back in case i miss the email if that is ok?

    P

    • This reply was modified 1 week ago by  patdundee.
    • This reply was modified 1 week ago by  patdundee.
    • This reply was modified 1 week ago by  patdundee.
    • This reply was modified 1 week ago by  patdundee.
    • This reply was modified 1 week ago by  patdundee.
    • This reply was modified 1 week ago by  patdundee.
    • This reply was modified 1 week ago by  patdundee.
    #21930

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #21931

    patdundee
    Participant

    Hi Ally

    Many thanks. I have replied to the email. Thanks for the other items you noted on the functions page. I will correct these in a while 🙂
    P

    #21932

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #21935

    patdundee
    Participant

    Shall wait for the V2.0.2 🙂

    The hidden fields are hidden if you select General enquiry as the extra info is not required. These only show if you select cake enquiry 🙂

    P

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.