Disable mobile keyboard on input date

Home Forums Quform WordPress Disable mobile keyboard on input date

This topic is: resolved

This topic contains 15 replies, has 2 voices, and was last updated by  EWP 3 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #28369

    EWP
    Participant

    Hello,

    When I’m on mobile and I click on a date field it briefly show the datepicker but then it scroll a little to the bottom and the datepicker vanished and the keyboard from the mobile show up.
    It is really annoying.
    The keyboard is above the datepicker so I don’t have a lot of space to move the screen so I can choose my date…
    And even then… when the keyboard show up and I click on the datepicker, it close the datepicker but doesn’t enter any date value in the field.

    You can see the behaviour on a mobile on your example page: https://www.quform.com/examples/elements

    How can we solve this or remove the auto-open mobile keyboard on datepicker field?

    Can we make something like this solution: https://github.com/Eonasdan/bootstrap-datetimepicker/issues/1668#issuecomment-323450298 working on Quform please?

    #28386

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    • This reply was modified 6 months, 3 weeks ago by  Ally.
    #28388

    EWP
    Participant

    Hi Ally,

    Thank you for replying.

    Can we make the all input clickable (and not just the tiny icon on the right of the input)?

    Because when I enable “Read only” and deactivate “Auto open datepicker” I can only open the datepicker by tapping on the little menu icon and when I click/tap on the input nothing happen and customer who want to fill the field might be confuse.

    Thank you!

    #28412

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #28431

    EWP
    Participant

    Hi Ally,

    Email sent to info@themecatcher.net by transferring the email I received from this feed.

    Thank you to let me know !

    #28478

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #28480

    EWP
    Participant

    Hi,

    It now works properly, thanks for the update!

    #29105

    EWP
    Participant

    Hi,

    I still have issue regarding datepicker on mobile.
    I have those settings enabled:
    – Auto open datepicker
    – Read only

    On an Android device (in my case I test with a Xiaomi Mi A1 with Android 9, so not my device’s fault, it’s new and latest Android version) I tested the field and it’s glitchy. Let me explain.

    → Basically when I tap/touch on the field itself it open the datepicker but when I click on a date it doesn’t write it on my field.

    The date is displayed correctly in my input only after this case:
    – I click on the calendar icon (THIS is the important step to make it work)
    – It open the datepicker
    – I can navigate through the month with the left and right arrow on the top of the datepicker (when I cliked on the input itself anywhere I clicked on the datepicker closed it and no date displayed in the input field)
    – I click on a date
    – The date is displayed in my input field (SO in this case it’s working)

    I guess taping on the field and not on the icon make it doesn’t work.
    So it’s a huge issue, because I need my datepicker to work (when I click anywhere on my input field) on mobile, not hoping the visitor of the website to tap only on the calendar icon and not on the field as it’s a basic behavior.

    Can you fix this issue? By simulate a click on the icon itself when we click on the input everywhere else but not the calendar icon? Or simply make it work by default when we open the datepicker by taping the field itself (and not the calendar icon).

    Thanks you.

    • This reply was modified 4 months, 1 week ago by  EWP.
    #29127

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #29167

    EWP
    Participant

    It’s on real device that it’s not working, don’t test on browser it’s not the same behavior.

    When I disable “Read only”, it opens again the mobile keyboard and the datepicker is hidden behind the keyboard.

    When you scroll, it close the datepicker. So it’s a no-go option.

    Need a fix for that please, thanks.

    #29170

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #29175

    EWP
    Participant

    Hi,

    I hope the new version will fix this problem, really…

    Let me know when you’ll update the quform plugin please.

    Thank you.

    #29182

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #29183

    EWP
    Participant

    Hi,

    Updated to Version 2.8.0, clear cache of everything and still the same.

    Can I send you in private the link to the form I have the issue? So you can test it on the form I have the problem.

    Really need to fix this.

    Thanks you.

    #29184

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.

Be inspired. © 2019 ThemeCatcher Ltd. 20-22 Wenlock Road, London, England, N1 7GU | Company No. 08120384 | Built with React | Privacy Policy