Quform Popup with Custom JS Causing other Buttons To Not Work at All

Home Forums Quform WordPress Quform Popup with Custom JS Causing other Buttons To Not Work at All

This topic is: resolved

This topic contains 6 replies, has 2 voices, and was last updated by  easytracgps 6 days, 6 hours ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #28408

    easytracgps
    Participant

    Hi,

    I’m stuck and I really hope you can help. I just implemented quform popups throughout our entire site in a staging environment and, due to a rookie mistake, I pushed the site live without testing all of the button functionality first. All of the popup buttons are working fine but, it seems that the custom js is causing other buttons with the same id to not open their link. So I’m trying to figure out how to solve this conflict without having to restore a backup and lose 3 days worth of work.

    Here’s our homepage: https://www.easytracgps.com/. If you scroll down below the fold you’ll see 3 inline elements with buttons labeled “Learn More” “Shop Devices” and “Learn More”. The Shop Devices button is the only one of the 3 that works and, after some testing, we discovered that it was due to that particular button id not having any custom js assigned to it. We temporarily assigned custom js to that button id to test our hypothesis and sure enough, until we deleted the code, it wouldn’t work either. So basically we know what the problem is, we just don’t know how to fix it. Can you help, please? Thank you in advance!

    Cheers,

    Daniel

    • This topic was modified 1 week, 3 days ago by  easytracgps.
    #28430

    easytracgps
    Participant

    Just a follow up on my post. Ally, if you look at the following page, you’ll also see that the Buy Now button is actually a WooCommerce link to our shopping cart: EasyTracGPS.com. However, due to this conflict, that button is also opening the lightbox popup form. Which is weird because the button id’s are different.

    • This reply was modified 1 week, 3 days ago by  easytracgps.
    #28477

    easytracgps
    Participant

    Um, excuse me but does someone plan on answering my questions anytime soon? Why do we bother renewing support for our 7 Quform licenses if this is the kind of support that we can expect to receive?

    #28489

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #28513

    easytracgps
    Participant

    Hi Ally,

    OK great, that worked. Thank you so much! Really appreciate it.

    Now, while I have you, one last thing. I think I’m having an issue with the CSS z-index property. On our pages, we have Let’s Chat buttons in our Revolution Sliders. However, the top of the forms are getting cut off because they are layered beneath another element. In this case, it is the primary menu that that is cutting off the top two fields in the form. You can see here on these pages for an example.

    https://www.easytracgps.com
    https://www.easytracgps.com/industries/cable-telecom-fleet/
    https://www.easytracgps.com/fleet-tracking-devices/

    Can you please take a look and let me know how to fix this? Thanks, much appreciated.

    Cheers,

    Daniel

    #28516

    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #28517

    easytracgps
    Participant

    That worked perfectly. Thank you again!

    Regards,

    Daniel

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Be inspired. © 2018 ThemeCatcher Ltd. 20-22 Wenlock Road, London, England, N1 7GU | Company No. 08120384 | Built with React | Privacy Policy