Server settings smtp-check

Home Forums Quform PHP Server settings smtp-check

This topic is: resolved
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #32769
    dubiousa
    Participant

    Hi my server needs following settings, which work in smtp-check.php
    $config[‘smtp’] = array(
    ‘host’ => ‘localhost’,
    ‘port’ => 25,
    ‘username’ => ”,
    ‘password’ => ”,
    ‘encryption’ => ”

    );
    $mailer->SMTPAutoTLS = false;
    $mailer->SMTPAuth = false;

    But a normal form is throwing an error:
    Fatal error: Uncaught PHPMailer\PHPMailer\Exception: SMTP Error: Could not connect to SMTP host. in /opt/home/XXX/public_html/quform/vendor/phpmailer/phpmailer/src/PHPMailer.php:2063

    How to apply my settings everywhere?
    Thanks!

    • This topic was modified 1 week, 5 days ago by dubiousa.
    #32771
    dubiousa
    Participant

    OK i’ve hacked the PHPMailer in line 2059 to
    if ($this->SMTPAutoTLS && $sslext && ‘ssl’ !== $secure && $this->smtp->getServerExt(‘STARTTLS’)) {
    $tls = false;
    }
    and it works.
    But i would rather prefer a cleaner solution. Open for ideas! Thanks!

    #32779
    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #32786
    dubiousa
    Participant

    Thanks! Works!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Be inspired. © 2020 ThemeCatcher Ltd. 20-22 Wenlock Road, London, England, N1 7GU | Company No. 08120384 | Built with React | Privacy Policy