Set Fancy Box width to 100%

Home Forums Quform WordPress Set Fancy Box width to 100%

This topic is: not resolved
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #9264
    dreoin
    Participant

    Hello,

    I have a form that pops up at a button click/tap which is used on an iPad. I’ve been playing with the Fancy box options, but I can’t seem to get it to work at 100%, I can only get it to work with discrete numbers like 1024×768.

    Here is a beta page with the form

    http://checkin.chcaa.com/form-beta/

    Here is my code:

    Tap Here to Check In
    [iphorm_popup id=11 options="{ width: 1024, height: 768, autoDimensions: false, onStart: function(){}, onComplete: function(){} }"][/iphorm_popup]
    <script type="text/javascript">// <![CDATA[
    jQuery(document).ready(function ($) { $('a[href="#form-11"]').click(function () { $('.iphorm-fancybox-link-11').click(); return false; }); });
    // ]]></script>

    I reviewed the information for Fancy Box options here:

    Fancybox options

    and reviewed some of the API info at
    http://fancybox.net/api

    The autoScale=false doesn’t seem to work.

    Any recommendations would be appreciated.

    DrEoin

    #9297
    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #9355
    dreoin
    Participant

    Hi Ally,

    Excellent advice as usually, this worked great. I have only one additional follow up to this question:

    One of the fancybox options is scroll bars: scrolling: ‘auto’ or ‘yes’ or ‘no’, set to auto or yes, I can only get the scroll bars to appear if I set the height: ‘px’ rather than ‘%’. Otherwise the bars don’t come up. Any recommendations, is there a default I need to change in quform or on the form itself?

    Thanks!

    Eoin

    #9389
    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

    #30715
    michi_w
    Participant

    Hi, read through some posts, still can’t figure out why my pop up is not behaving the way i’d like it to do.

    Placed it in the footer-widget area with a shortcode:

    [quform_popup id="1" name="Contact" options="{ width: '100%', height: '100%', autoDimensions: false, onStart: function(){}, onComplete: function(){} }"][dt_default_button link=”|title:Contact||” size=”custom” btn_width=”btn_full_width” button_alignment=”btn_left” font_size=”20px” icon_size=”20px” button_padding=”16px 20px 16px 20px” border_radius=”0px” text_color=”#000000″ default_btn_border=”n” default_btn_bg_color=”#ececec” text_hover_color=”#ffffff” default_btn_border_hover=”n” bg_hover_color=”#76777a” css=”.vc_custom_1583080179430{margin-top: 5px !important;margin-right: 5px !important;margin-bottom: 5px !important;margin-left: 5px !important;}”]Contact[/dt_default_button][/quform_popup]

    added the options – still it only has about the size of the widget area it is in? Actually i’d like it to be width:’720px’
    Could you advise please?
    Appreciate your help!

    #30727
    Ally
    Support Staff

    You don't have permission to view this content. Please log in or register and then verify your purchases to gain access.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Be inspired. © 2020 ThemeCatcher Ltd. 20-22 Wenlock Road, London, England, N1 7GU | Company No. 08120384 | Built with React | Privacy Policy